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1. Introduction 
 

As an addendum to the article “Ground Gain in Theory and Practice” published in the magazine 
DUBUS 3/2011, this document describes the measurement protocol steps to be performed in order 
to assess one’s own Ground Gain geometry and magnitude or in a more general way one’s own 
antenna elevation pattern in presence of ground effects. The emphasis is on 144 MHz but it could be 
applicable to other bands through some customization. 
The following equipment is required : 
 

 A SSB capable receiving chain with an AGC disabling capability. 

 A computer ; any current one will do the job. 

 A soundcard, either embedded in the computer or external. 

 A link between the receiving chain audio output and the computer soundcard input (Line IN), 
with a way to adjust the audio level in between. 

2. Preparation 

2.1. Step 1 : extract the package content 
 
Unzip the content of the package to the root directory C:\. Don’t do it somewhere else (i.e. in 
another directory), otherwise the Excel macros devoted to data processing will fail to work. 
You will get a directory with the following structure : 
 

 

In the different directories, you will find : 

 Documentation : 

o The present document, Ground Gain Measurement Procedure v1-0.pdf 
o Precedings of the IRE - Scatter Propagation Issue – Part 1, IRE 1955 Part 1.pdf 
o Precedings of the IRE - Scatter Propagation Issue – Part 2, IRE 1955 Part 2.pdf 

 Measurement campaigns : 

o Examples of real measurements 

 Softwares : 

o Spectrum Lab v2.76 b8 (by DL4YHF), Spectrum Lab 2-76.zip 
o Configuration file Ground Gain Measurement.usr for Spectrum Lab 
o GJTracker (by W7GJ), GJTRACKER.zip 

 Tools : 

o Ground Gain Geometry and Magnitude Calculator File.xlsm which is a theoretical 
simulator (MS Excel 2007). 

o Ground Gain Sun Noise Measurement Processing File.xlsm, the file (MS Excel 2007) to 
process the sun noise measurement data records and its desktop shortcut. 
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2.2. Step 2 : install and configure Spectrum Lab 
 

 Install Spectrum Lab in whatever directory (this one not necessarily C:\). I’m using Spectrum 
Lab under MS Windows XP SP2. 

 In the directory where Spectrum Lab is installed, create the following sub-directories : 
o Captures 
o Logging 

 Move the file Ground Gain Measurement.usr provided in the measurement package to the 
sub-directory configurations of Spectrum Lab. 

 Start Spectrum Lab (icon on desktop). 
 In the menu toolbar, select File > Load Settings From.. : 

o Go to the sub-directory configurations and choose the file Ground Gain 
Measurement.usr. 

o Click on Open. 
 

 

This file contains the customized configuration required for the measurement. You need however 
some more own customization. 
 

 In the menu toolbar, select Options > Audio settings, I/O device selection : 
o In the tab Audio I/O of the new window, select your own particular soundcard 

(Audio Input Device) amongst the list. According to your particular soundcard, it 
could be required to change also the Soundcard Sample Rate (e.g. 11025 Hz instead 
of 44100 Hz as for mine). 

o If you also want to listen (but it will just be noise), select the Audio Output Device 
too. 

o Click on Apply and Close. 
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 In the menu toolbar, select Options > System settings > Timezone, Time source, Timer 
Calibration : 

o In the tab Loc, Timezone, Time source, set Local time MINUS UTC(GMT) according to 
your location. 

o Click on Apply and Close. 
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For example in Belgium in winter, we are at UTC+1h local time (UTC+2h in summer)  e.g. UTC is 
12:00, local time is 13:00 in winter (14:00 in summer). So, Local time MINUS UTC(GMT) is 1 (13-12) 
in winter and 2 in summer. 
The computer must be synchronized on a NTP time server (there are many softwares to achieve this, 
e.g. D4, Chronos, Meinberg,…). 

 

 Finally, in the menu toolbar, select File > Save Settings As.. : 
o Replace SETTINGS.INI by Ground Gain Measurement.usr chosen in the list. 
o Click on Save. 

 

 

That is all, don’t change anything else ; FFT, noise measurement formulas,… are already included in 
the Ground Gain Measurement.usr file. 
 

 Close Spectrum Lab. For the subsequent measurements, Spectrum Lab is now configured 
once and for all. 
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2.3. Step 3 : install and configure GJTracker 
 

 Install GJTracker (provided in the measurement package) on your computer, wherever you 
wish (in any directory). 

 Start GJTracker and configure with your own data according to the following screenshot : 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

o Lines per output page : set to “3600” (to ease subsequent processing work). 
o Computer Clock Hours minus UTC : set in the same way as for Spectrum Lab, 

explained in section 2.2. 
 

 Click on SET DEFAULTS, so that at next start all but the date will remain the same. GJTracker 
is now installed once and for all. 

 Exit (close) GJTracker. 
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3. Measurement 

3.1. Step 1 : plan the measurement 
 
As an example, let’s define the measurement takes place on April 2nd, 2011. 
 

 Open GJTracker. 

 Set Start Date, then End Date to “Apr 2 2011”. 

 Click on RUN. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Here is an extract of the output text file : 
 

 
 

 Save this file under the name Sun Az-El.txt in the directory C:\Sun Noise Measurement. 
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It is important to respect the naming convention given here (both directory and file names), 
otherwise the processing macros in Excel won’t work ! 

 

 Exit (close) GJTracker. 
 

On April 2nd, 2011 for my location, the sun rises at 05:24 UTC (azimuth 82.4°) and sets at 18:12 UTC 
(azimuth 277.9°). 
 

3.2. Step 2 : equipment warm-up 
 
Equipment settings and conditions for a reliable measurement are as follows : 
 

 Transceiver or receiver AGC (Automatic Gain Control) set to OFF. 
 Transceiver or receiver set in SSB mode (200-2200Hz bandwidth required). 

 Whole receiving chain (RX and soundcard) assumed to be linear. 

 Transceiver or receiver Noise Blanker (NB) set to ON. The white noise to be measured is 
normally not altered by the NB, while the pulse noises (disturbing the measurement) will be 
suppressed. 

 A clear frequency, not subject to disturbances (QRM). 

 The whole station and computer powered ON at least 12 hours before performing the 
measurement, so that the whole setup is stable and at temperature during the 
measurement. 

 Good weather with no wind or rain to avoid static noise. 
 

3.3. Step 3 : reference noise (Nreference) 
 
When the sun is below -10° elevation for a sun rise measurement or above +35° elevation for a sun 
set measurement : 
 

 Connect a 50Ω load at the input of the RX chain, as depicted below : 
 

 

 

 

 

 

If you are not using a transverter, consider placing a preamp. in front of the transceiver or receiver, 
particularly if this last is a commercial model, to overcome the possible poor sensitivity and to allow 
the small (sun) noise variations (few dB’s) to be noticed. In this case, the RX chain will look like : 
 
 
 
 
 
  

Transverter 

RX 

Transceiver BP Filter 
Preamp. Mixer Amplifier 

  Feeder 

50Ω load at room 

temperature 

RX 

Transceiver Preamp. 

50Ω load at room 

temperature 
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 Start Spectrum Lab. 

 Adjust the audio level out of the transceiver or receiver to get the yellow curve on the 
spectrum window around -50/-60 dB (this is not critical). Once adjusted, don’t touch it 
anymore during the course of the subsequent steps of the measurement. 
 
 
 

 
 
 
 
 

 

 Adjust the colour palette sliders as you wish. Don’t touch it anymore afterwards. 
 
 
 
 
 
 
 
 

 In the menu toolbar, select File > Text file export > Export of calculated data : 
o In the tab Filename & Activation, type in the file name as shown on the screenshot 

below (Nreference.txt). 
o Click on Apply. 

 

 
 

It is very important to click on Apply, otherwise the measurement will further proceed on the 
previously named file. 
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To effectively start the measurement : 
 

 Check in the checkbox Active. The Size will start to grow. 

 Leave the measurement running up to when the Size has reached around 500 to 1000 (not 
critical). 

    
 

 Uncheck the checkbox Active to stop the measurement. 
 

You can click on OK to close the window, but it is not required at this stage to close this window ; 
leave it open. 
 

 
 

3.4. Step 4 : background noise before sun noise measurement (Nbgd 
PRE) 

 
Once Step 3 is completed : 
 

 Disconnect the 50Ω load and connect the antenna line. Don’t forget to set the external 
(masthead) preamp. in by-pass mode. 

 

 

 

 

 

 

 

 Rotate the antenna towards the first azimuth onto which Nbgd has to be measured. 
 
For the example given here, the azimuth span ranges from 65° to 140°. Let’s start with 65°. 
 

 Direct your antenna to 65° azimuth. 

 In Spectrum Lab name the data to record as on the screenshot below (Nbgd 65deg PRE.txt). 

Transverter 

RX 

System 

Antenna 

Transceiver 

Jumper 
BP Filter 

Preamp. Mixer Amplifier Preamp. 

Feeder 1 Feeder 2 
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 Click on Apply  

 Check the Active checkbox to start the measurement. The Size starts to grow every 10 
seconds. 

 Leave the measurement running until the Size has reached around 500 to 1000 (not critical). 
 

    

 Uncheck the checkbox to stop the measurement. 

 Then rotate the antenna towards 70° : 
o Update the file name (now Nbgd 70deg PRE.txt instead of Nbgd 65deg PRE.txt as 

above). 
o Click on Apply. 
o Check the Active checkbox and uncheck it once the size has reached 500 to 1000. 

 
And so on up to 140° azimuth, per 5° azimuth steps. 
 
The overall sequence is as shown hereunder. 
 
In the menu toolbar, select File > Text file export > Export of calculated data : 

 
 Name the data file to record (mandatorily as Nbgd xdeg PRE.txt ; x = 0 to 

360). 
 
 Click Apply. 

 
 Check in checkbox Active to start. 

 
 Once size has reached 500 to 1000, uncheck to stop. 

Azimuth x+5° 



Page | 14  

3.5. Step 5 : sun noise (Nsun) 
 
Right after Step 4 has been performed, the sun should be around -5° elevation for a sun rise 
measurement or around 30° elevation for a sun set one. Measure the sun noise in tracking mode up 
to around 30° (sun rise) or down to around -5° elevation (sun set). “Tracking mode” suggests an 
automatic way for the antenna to follow the motion of the sun in azimuth ; otherwise, you need to 
manually adjust the antenna position from time to time. 
 
Once the antenna is set to the proper azimuth and ready to follow the motion of the sun, go to the 
menu toolbar of Spectrum Lab, select File > Text file export > Export of calculated data : 
 

 Name the data file to record, mandatorily as Nsun.txt. 

 Click on Apply. 
 

 
 

 Check in checkbox Active to start (*). 

 Let the measurement running and once the sun is out of range, i.e. above 30° elevation (sun 
rise) or below -5° elevation (sun set), uncheck Active to stop. 

 
This measurement can take several hours, according to your latitude and period of the year. 
 
To allow identifying a posteriori if some disturbance occurred during the measurement, it is wise to 
activate screenshot captures prior to start the measurement (*). To accomplish this, follow the steps 
below. 
 

 In the menu toolbar, select File > Screen Capture > Screen Capture options.. : 
o In the tab Screen Capture, Set File Index to 1 and Filename to any name you want 

(no specific naming convention required here). 
o Click on Apply. 
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o In the tab Periodic Actions, check in the checkbox active and then OK. 
 

 

This will generate a screenshot capture named Capt Sun Rise 02042011-1. After 12 minutes, the next 
capture will be Capt Sun Rise 02042011-2 and so on every 12 minutes throughout the whole 
measurement. 
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3.6. Step 6 : background noise after sun noise measurement (Nbgd 

POST) 
 
When the sun is out of influence (above +35° for a sun rise or below -10° elevation for a sun set), 
repeat exactly (over the same azimuth span) the measurement performed at step 4 but in the data 
file names, use here POST instead of PRE. 
 
For example, Nbgd 70deg PRE.txt at step 4 will be now Nbgd 70deg POST.txt. 
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4. Post processing 

4.1. Process the data files 
 
Since the measurement data collection is now finished, we can move to the next step which is the 
process of the data. 
 

 Copy the files included in the sub-directory Logging of Spectrum Lab to C:\Sun Noise 
Measurement. 

 Delete these files from the same sub-directory Logging of Spectrum Lab, otherwise any 
future measurement will further proceed on the preceding files if these are not deleted. 
 

In the directory C:\Sun Noise Measurement, you have now the following types of files : 
 

Sun Az-El.txt Azimuth & elevation of the sun 

Nreference.txt Reference noise level when RX chain connected to a 50Ω load (calibration) 

Nbgd xdeg PRE.txt Background noise when RX chain connected to the antenna, before the sun 

noise measurement, per 5° azimuth steps 

Nsun.txt Sun noise in manual or automatic tracking mode from -5° (sun rise) or 30° 

(sun set) elevation to 30° (sun rise) or -5° (sun set) elevation 

Nbgd xdeg POST.txt Background noise when RX chain connected to the antenna, after the sun 

noise measurement, per 5° azimuth steps 

 

 In the sub-directory Tools provided with the package, open the file Ground Gain Sun Noise 
Measurement Processing File.xlsm. 
 

 (1) : In the drop down lists on the left, select the measurement type, azimuth range and date. 

 (2) : Click on Clear All prior to launch any new file upload. 
 

 

(1) 

(2) 
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 (3) : In the field File to upload, select alternatively : 
 

o Az. – El., then click on Upload File in front of the corresponding file name (Sun Az-El), 
preceded by File to upload highlighted in orange in the column Action. 
 

 
 

o REFERENCE, then click on Upload File in front of the corresponding file name 
(Nreference), preceded by File to upload highlighted in orange in the column Action. 

o PRE, then click on Upload File in front of the corresponding file name (Nbgd xdeg 
PRE), preceded by File to upload highlighted in orange in the column Action. 
 

 
 

o SUN, then click on Upload File in front of the corresponding file name (Nsun), 
preceded by File to upload highlighted in orange in the column Action. 

o POST, then click on Upload File in front of the corresponding file name (Nbgd xdeg 
POST), preceded by File to upload highlighted in orange in the column Action. 
 

 

(3) 
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When the files are uploaded, the status becomes File uploaded, highlighted in green. 

 

 (4) : Click on RSF & Station Data, you get the following window : 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 According to your specific RX station data, fill in only the cells highlighted in yellow (all the 
others in grey show calculated figures). If you are not using a transverter, refer to the 
Annexes (section 6.1.). 

 Select the RSFx (x is the frequency band) calculation method and fill in the associated RSF 

figure, prompted by a dynamic cell highlighted in dark red. Two methods are possible : 
 

o Method 1 : a polynomial law that extrapolates the RSF2800 (2800 MHz) down to 144 
MHz, thanks to the data got from the U.S. Space Weather Prediction Centre website : 
http://www.swpc.noaa.gov/ftpdir/lists/radio/rad.txt 

 
 
 

(4) 

http://www.swpc.noaa.gov/ftpdir/lists/radio/rad.txt
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Example of a U.S. Space Weather Prediction Centre data : 
 

 
 

 
 

o Method 2 : data out of the EME Calculator of Doug, VK3UM. In this case, data for 
other bands than only 144 MHz are also available. 
The software can be downloaded here : http://vk3um.com 
If it is about using this software only to derive de RSF figures, there is no need to 
configure it, just install it anywhere on you computer. 
 
In VK3UM EME Calculator, click on GET IPV SFV DATA at the top left of the window. 
A new window (IPS Update) appears. Click on Current IPS Flux Data. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

http://vk3um.com/
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The data got from the EME Calculator of VK3UM have proven to be more reliable in case of high or 
stormy solar activity. 
 

 Click on Go Back at the bottom right of the window to come back to the previous 
window. 

 In this previous window, click on Process Files. 
 

 

 

4.2. Publish the Report 
 
Once the files are processed, you get two resulting charts. Here a manual operation is required on 
both charts before completion. 

4.2.1. Sun rise measurement 

 
In MS Excel (2007) : 

 In the menu toolbar, select Layout > Axes > Primary Vertical Axis > More Primary Vertical 
Axis Options... 
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o The window on right (Format Axis) pops 
up. 

o Copy the Azimuth min. figure on the 
chart to the field Minimum in the Axis 
Options (here 77.9). 

o Copy the Azimuth max. figure on the 
chart to the field Maximum in the Axis 
Options (here 116.4). 

o Click on Close. 
 

 

 

 

 

 

 

 In the menu toolbar, select Layout > Axes > Secondary Vertical Axis > More Secondary 
Vertical Axis Options... 
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o The window on right (Format Axis) pops 
up. 

o Copy the Elevation min. figure on the 
chart to the field Minimum in the Axis 
Options (here -3.6). 

o Copy the Elevation max. figure on the 
chart to the field Maximum in the Axis 
Options (here 25.9). 

o Click on Close. 
 

 

 

 

 

 

 

4.2.2. Sun set measurement 

 
Proceed exactly as described in section 4.2.1. ; the only difference is that in the window Format Axis 
which appears when you select Layout > Axes > Primary Vertical Axis > More Primary Vertical Axis 
Options... in MS Excel, you have to check in the checkbox Values in reverse order. Then Close. 
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4.2.3. Completion 

 
On the Ground Gain graph (the second resulting chart), the Theoretical GG pattern (purple dashed 
curve) shows by default the elevation pattern of a 12-element DK7ZB at 17.3m agl over a perfect and 
flat ground. You can change this and select another antenna type, type of ground, antenna height 
and a flat or downwards tilted ground. 
To achieve this, you have to : 

 Open the file Ground Gain Geometry and Magnitude Calculator File.xlsm provided in the 
package (directory C:\Sun Noise Measurement\Tools). 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Select the Type of Ground and Antenna Type and fill in the Frequency, Height and Ground 
slope. You have the choice between a few antenna types, ranging from a dipole to a stack of 
2x12-element antennas (144 MHz). 

 Save this file (don’t change its name) in C:\Sun Noise Measurement\Tools (nowhere else) 
and close it. 

 Come back to the currently open file (Ground Gain Sun Noise Measurement Processing 
File.xlsm) and click on Refresh and Include Theoretical GG Pattern. 

 

 

It is also possible to import your own antenna pattern ; refer to the Annexes (section 6.2.). 
 

 You can also include some comments in the report (at the bottom of the Ground Gain 
graph). 
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 Click on Publish Report at the top of the page. 

 

 

You have now a file named Ground Gain Sun Noise Measurement Processing File.pdf in the directory 
C:\Sun Noise Measurement. 

 

 Rename this file in a more explicit way, e.g. Ground Gain Sun Rise ddmmyyyy.pdf 

 Move this file Ground Gain Sun Rise ddmmyyyy.pdf, together with the Sun Az-El.txt, 
Nreference.txt, Nbgd xdeg PRE.txt, Nsun.txt and Nbgd xdeg POST.txt files somewhere else on 
your computer (wherever you wish, no specific convention required here). 

 Delete these files from C:\Sun Noise Measurement ; this is mandatory to avoid disturbing the 
future measurements. 

 

5. Additional information 
 
The Ground Gain graph indicates the geometry and magnitude of the Ground Gain lobes (or antenna 
elevation pattern) but only the magnitude of the first lobe (the less elevated one) is reliable, since 

the calculated sun noise rise (NRsun) is not weighted according to the free space antenna radiation 
pattern in the elevation plane. This will perhaps be updated in a future release of the tools. 
 
To train how the file processing works, you can temporarily copy the measurement files provided as 
examples and available in the sub-directories (sorted by dates) part of the directory Measurement 
Campaigns. 
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6. Annexes 

6.1. If not using a transverter 
 
As written previously in this document, it is recommended to place a preamplifier in front of the 
transceiver (or receiver), all the more any external (masthead) preamplifier has to be set in by-pass 
mode to meet the calculation spreadsheets constraints. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.2. Import your own antenna pattern 
 
Explaining how to model antennas is beyond the scope of the present document. However, it is 
shown here how to export a free space elevation radiation pattern out of the modelling software 
MMANA-GAL (http://hamsoft.ca/pages/mmana-gal.php). Once your antenna has been modelled and 
its pattern calculated : 
 

 In the menu toolbar of MMANA-GAL, select File > Table of Angle/Gain (*.csv). 

 In the new window which has pop up, enter the figures for the Azimuth and Zenith fields 
exactly as shown below. 

 Enter the name Other Antenna Pattern.csv (and no other name, otherwise the processing 
macro won’t work), to be saved under C:\Sun Noise Measurement (and nowhere else). 

 Click on OK. 

 Exit (Close) MMANA-GAL. 

RX 

Transceiver Preamp. 

Given the stages in red on the schematic below are not 
applicable here, the corresponding cells also highlighted 
in red in the table have to be filled in with 0 when 
encoding the RX station data (see section 4.1.) 

http://hamsoft.ca/pages/mmana-gal.php
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 (1) : In the file Ground Gain Geometry and Magnitude Calculator File.xlsm (see section 4.2.3.), 
select the Type of Ground, fill in the Frequency, Height and Ground slope. 

 (2) : Select Antenna Type as “Other antenna”. 

 (3) : Replace “Name as you wish” in the cell highlighted in yellow by the name of the 
antenna to import (any name is allowed here, no specific convention required). 

 (4) : Click on Import Other Antenna. 

 Save this file (don’t change its name) in C:\Sun Noise Measurement\Tools (nowhere else) 
and close it. 

 

 

 

 

 

 

 

 
Further proceed on the completion of the processing according to the explanation given in section 
4.2.3. 

(1) 

(1) 

(2) (3) 

(4) 


